Article

Table of Contents
Try Vultr Today with

$50 Free on Us!

Want to contribute?

You could earn up to $300 by adding new articles!

How to Install Flarum Forum on Debian 10

Published on: Mon, Jan 6, 2020 at 8:01 am EST
Debian Linux Guides Server Apps Social

Flarum is a free and open source next-generation forum software that makes online discussion fun. It's simple, fast, and free. Flarum source code is hosted on Github. It is designed to be fast, simple, responsive and extensible.

This guide will walk you through the Flarum installation process on a fresh Debian 10 (buster) Vultr instance using PHP, MariaDB as a database, and Nginx as a web server.

Requirements

Before you install Flarum, it's important to check that your server meets the requirements. To run Flarum, you will need:

  • Apache (with mod_rewrite enabled) or Nginx. This guide will use Nginx.
  • PHP version 7.1 or greater with the following PHP extensions: dom, gd, json, mbstring, openssl, pdo_mysql, tokenizer.
  • MySQL version 5.6 or greater or MariaDB version 10.0.5 or greater. This guide will use MariaDB.

Before you begin

Check the Debian version.

lsb_release -ds
# Debian GNU/Linux 10 (buster)

Create a new non-root user account with sudo access and switch to it.

adduser johndoe --gecos "John Doe"
usermod -aG sudo johndoe
su - johndoe

NOTE: Replace johndoe with your username.

Set up the timezone.

sudo dpkg-reconfigure tzdata

Ensure that your system is up to date.

sudo apt update && sudo apt upgrade -y

Install the needed packages.

sudo apt install -y zip unzip curl wget git

Install PHP

Install PHP, as well as the necessary PHP extensions.

sudo apt install -y php php-cli php-fpm php-common php-mbstring php-gd php-xml php-mysql php-curl

Check the version.

php --version

# PHP 7.3.4-2 (cli) (built: Apr 13 2019 19:05:48) ( NTS )
# Copyright (c) 1997-2018 The PHP Group
# Zend Engine v3.3.4, Copyright (c) 1998-2018 Zend Technologies
#     with Zend OPcache v7.3.4-2, Copyright (c) 1999-2018, by Zend Technologies

Install MariaDB

Install MariaDB.

sudo apt install -y mariadb-server

Check the version.

mysql --version
# mysql  Ver 15.1 Distrib 10.3.15-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

Run the mysql_secure_installation script to improve the security of your MariaDB installation.

sudo mysql_secure_installation

Log into MariaDB as the root user.

sudo mysql -u root -p
# Enter password:

Create a new MariaDB database and database user, and remember the credentials.

MariaDB> CREATE DATABASE dbname;
MariaDB> GRANT ALL ON dbname.* TO 'username' IDENTIFIED BY 'password';
MariaDB> FLUSH PRIVILEGES;
MariaDB> quit

NOTE: Replace dbname and username with appropriate names for your setup. Replace password with a strong password.

Install Nginx

Install Nginx.

sudo apt install -y nginx

Check the version.

sudo nginx -v
# nginx version: nginx/1.14.2

Configure Nginx for Flarum. Run sudo vim /etc/nginx/sites-available/flarum.conf and populate the file with the following configuration.

server {

  listen [::]:80;
  listen 80;

  server_name example.com;
  root /var/www/flarum/public;

  index index.php;

  location / {
    try_files $uri $uri/ /index.php?$query_string;
  }

  location ~* \.php$ {
    fastcgi_pass unix:/run/php/php7.3-fpm.sock;
    include fastcgi_params;
    fastcgi_index index.php;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
  }

}

Save the file and exit with :+W+Q.

Activate the new flarum.conf configuration by linking the file to the sites-enabled directory.

sudo ln -s /etc/nginx/sites-available/flarum.conf /etc/nginx/sites-enabled/

Test the configuration.

sudo nginx -t

Reload Nginx.

sudo systemctl reload nginx.service

Install Composer

Download and install Composer, the dependency manager for PHP.

php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"
php -r "if (hash_file('sha384', 'composer-setup.php') === 'a5c698ffe4b8e849a443b120cd5ba38043260d5c4023dbf93e1558871f1f07f58274fc6f4c93bcfd858c6bd0775cd8d1') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
php composer-setup.php
php -r "unlink('composer-setup.php');"
sudo mv composer.phar /usr/local/bin/composer

Check the version.

composer --version
# Composer version 1.9.0 2019-08-02 20:55:32

Install Flarum

NOTE: Flarum is currently in the beta stage. It is not recommended to run it in production just yet unless you know what you are doing. You should wait for stable release for production usage.

Create a document root directory.

sudo mkdir -p /var/www/flarum

Change ownership of the /var/www/flarum directory to johndoe.

sudo chown -R johndoe:johndoe /var/www/flarum

Navigate to the document root folder.

cd /var/www/flarum

Download the latest release of Flarum via composer.

composer create-project flarum/flarum . --stability=beta

NOTE: You may run out of memory when installing Flarum via Composer. If that happens, then you'll need to setup Swap.

Change ownership of the /var/www/flarum directory to www-data.

sudo chown -R www-data:www-data /var/www/flarum

Open your site in a web browser and follow the instructions on the screen to finish the installation.

Want to contribute?

You could earn up to $300 by adding new articles